Anywhere365 Attendant Console for Microsoft Teams | Global | Dekstop Integrator

Incident Report for AnywhereNow

Resolved

Dear Anywhere365 customers and partners,

We appreciate your patience as we continue to work on enhancing our services. Here's the latest update on ongoing developments:

Desktop Integrator Progress:
We are actively addressing issues with the Desktop Integrator to ensure it functions seamlessly. While progress is being made, we want to acknowledge that a guaranteed resolution is not yet confirmed. Rest assured, our team is dedicated to achieving the best possible outcome.

Improvements to ACS:
We are aware of issues related to one-way audio during the use of Attendant Console within the Teams application. Efforts are underway to rectify these issues and provide a smoother experience together with Microsoft.

Communication Channels:
We will be closing this status message but moving forward, all updates related to these issues will be communicated through the new release notes. Additionally, when a new release is made, you will be notified through the "What's New" pop-up within the Attendant Console for Teams.

We understand the importance of these features for your workflow and are committed to delivering reliable solutions.

Thank you for your continued support.

Best Regards,

Anywhere365 – Incident Management
Posted Dec 12, 2023 - 10:21 UTC

Update

Dear Anywhere365 Customer & Partner,

We would like elaborate on the Attendant console for Teams maintenance planned for the EMEA region on 5 September 2023: https://status.anywhere365.io/incidents/lx36jpmgsfs5

This maintenance will be a partial update since it will update the Attendant Console to include the features and fixes introduced in MT2023.03 and MT2023.04 while at the same time, keep the contact search functionality running on the same version it is on currently to ensure minimal impact to the service and that the update will proceed successfully.

To highlight, these are the release notes related to the Desktop Integrator and ACS:

Introduction of ACS:
https://golive.anywhere365.io/release_notes/acft-release-notes/release-notes-attendant-console-teams-mt2023.04.htm

Additional documentation on how to enable ACS in the Attendant Console:
https://golive.anywhere365.io/platform_elements/attendant-console/attendant-console-for-teams/attendant-console-for-teams-acs.html

A workaround that enables operators to still use the Desktop Integrator in a browser (https://attendant.anywhere365.io)
Please view item 90900 in the below release note for more info:
https://golive.anywhere365.io/release_notes/acft-release-notes/release-notes-attendant-console-teams-mt2023.03.htm

Lastly, to ensure the fastest reaction time and communication flows in case of any issue during the maintenance, we have established extra capacity with a group of engineers that will be on duty monitoring incoming cases and are directly connected with relevant resources from other departments.

Best Regards,
Anywhere365 – Incident Management
Posted Sep 01, 2023 - 07:51 UTC

Update

Dear Anywhere365 Customer & Partner,

We would like to provide an overview of the timeline as it stands right now.
Please note that depending on the outcome of upcoming releases these dates might change, but it will be announced here on our status page.

The first release of Attendant console for ACS will be at:

Date: August 15th 09:00PM UTC

Region: AMER/NORA

https://status.anywhere365.io/incidents/7gx3bjjjqphd

If no issues are encountered we will move onto the next release:

Date: August 15th 12:00PM UTC

Region: APAC

https://status.anywhere365.io/incidents/mp1510j1rgbw

We will monitor these releases for 1 week, if no issues are encountered we will move onto the next release.

Date: August 22th 18:00PM UTC

Region: EMEA

https://status.anywhere365.io/incidents/bv2vvg4125wk

More technical details will follow.
Thank you for your patience and understanding while we are working on a solution.

Best Regards,
Anywhere365 – Incident Management
Posted Aug 04, 2023 - 11:57 UTC

Identified

Dear Anywhere365 Customer & Partner,

Our apologies for the delay in the update, but due to the complex nature of this issue it has taken longer than expected.

We would like to provide you with an important status update regarding the Desktop Integrator with an statement from our Product Owner.

Current Issue:

Although we have our test tenant running on a Beta ring and by having that we get deployed early versions of Teams, we have been surprised by the changes Microsoft has made in the latest versions of the Teams client. Specifically, the custom JavaScript function "window.open" is no longer supported, and there was no active communication on that change. We were using that function to connect to the Desktop Integrator when the Attendant Console is used in Teams.

Investigation and Impact:

Before the problems with the Desktop Integrator with the current Teams client arose, we had already initiated a process to determine the impact of the new Teams Preview client on various aspects, including the operation of the Desktop Integrator. However, due to the premature status of this new client and the limited information available, we have not yet been able to conclude on the possible integration with this new client.

Development and Release Plan:

Earlier this year, we started the development of bringing ACS (Azure Communication Services) into the Attendant Console to handle calls independently of the Teams client. The situation with the Desktop Integrator has urged us to expedite the development and release of this functionality.

Expected Release:

Our aim is to have a new release of the Attendant Console for Teams ready for release on the last week of August 2023. This new release will include all the new functionality of MT2023.03 together with ACS as MT2023.04.

New Functionality with ACS:

In this first version of the Attendant Console for Teams with ACS, we will provide the following features:
• Handling incoming calls in the queue.
• Direct and Consultative (cold and warm) transfers.
• Outgoing calls from the Attendant console.
• Changing the presence of Agents to Busy on a Call when handling Attendant Console calls.
• In addition to these call-related functions, all other non-call-related functions, such as contact search, callback notes, widgets, etc., will also be available.

Behavior Changes with ACS:

With the introduction of ACS, some changes in call handling behavior should be noted:

• ACS is mainly for handling calls picked up from the queue and not personal calls. A distinction will be made between queue calls, which will be handled in the Attendant Console, and personal calls, which will be handled in the Teams client.
• The Teams client will still need to be active to participate in chats and meetings, for presence, and for personal calls.
• When an agent is set to Busy in a Call due to handling a call in the Attendant Console, this status can be overruled by setting the presence in Teams itself.
• Deploying ACS will require customers to create a connection string in their Azure tenant, which will be configured in the Admin portal of the Attendant Console. Additional consent will be needed for this configuration.

GoLive and Release Date:

The procedure and manual for the additional ACS configuration will become available on GoLive prior to the actual release. For the exact release date, please keep an eye on our status page.

We understand the effect this has on your daily operations and are aware that the timeline towards the resolution is longer than we would have expected and liked to have this complex issue resolved.

We appreciate your understanding and patience as we work to resolve this issue and bring the enhanced functionality of Attendant Console for Teams with ACS as soon as possible.


Thank you for your continued support and cooperation.
Posted Jul 24, 2023 - 09:25 UTC

Update

Update - Dear Anywhere365 Customer & Partner,


Our developers continue working on an alternative for this feature.

In the meantime, we have released a new version of the desktop integrator to improve the experience using Attendant Console on the browser.
Download the Anywhere365 Desktop Integrator setup here:

https://delivery.anywhere365.io/deployment/msteams/Anywhere365IntegratorSetup.msi.

https://golive.anywhere365.io/platform_elements/attendant-console/additionalconfiguration/attendant-console-desktop-integrator-guide-teams.htm

We will update this communication next week.
Should you require further clarification or assistance, please follow regular contact channels through the ticketing system.

Thanks for your understanding and collaboration.

Best Regards,
Anywhere365 – Incident Management
Posted Jul 07, 2023 - 15:07 UTC

Update

Dear Anywhere365 Customer & Partner,

We would like to inform you that we keep working on a resolution for this functionality disruption.

The incident is escalated to our dev team with a higher priority. A possible solution was expected to be released this week; however, we found some technical challenges and (undesired) side effects that require further investigation and we had to postpone it. We are since yesterday also investigating an alternative. We can´t confirm the exact ETA yet, but we expect to be able to include a fix on the next release scheduled for next week, we´ll confirm this on Friday, Jul 07, 2023.



In the meantime, we advise you to use Attendant Console on different browsers (URL: https://attendant.anywhere365.io), as this workaround has been confirmed to work for most of the customers impacted. The alternative to this workaround is to manually accept the call on Teams after accepting it on Attendant Console, this has been confirmed to work for all customers impacted.



We want to reassure you that although this issue only affects to the Desktop Integrator functionality – and not the core functionalities-, all resources supporting this product are involved in the investigation to ensure the fastest resolution possible, as we understand the impact this may have on your daily operations.



Should you require further clarification or assistance, please follow regular contact channels through the ticketing system.

Thanks for your understanding and collaboration.

Best Regards,
Anywhere365 – Incident Management
Posted Jul 05, 2023 - 10:14 UTC

Investigating

We would like to provide you with an important status update regarding the Desktop Integrator for Attendant Console for Teams. We are aware of an issue that is affecting the functionality of the Desktop Integrator due to the new Teams update that was rolled out last week.
As a result of this update, the Desktop Integrator is currently not working as intended. We understand the inconvenience this may cause, and we want to assure you that our team is working diligently to address the issue.

It is important to note that this issue only impacts the functionality of the Desktop Integrator. Our core product, Attendant Console for Teams, is still working as intended. However, please be aware that for the time being, users will need to manually answer calls within Teams while using the Attendant Console.

We apologize for any disruption or inconvenience this may cause in your daily operations. As soon as we have any updates or solutions, we will notify you here on our status page.
Posted Jun 30, 2023 - 07:24 UTC